upgrade - rpm yum install : how to put conflicts on an already installed package?

I'm trying to stop installation of an rpm if I have a particular version of a package already installed.Say I have 2 packages A-7.1.1.rpm & Main_package-1.0.rpm to be installed.And I've A-1.4.0.rpm already installed on the machine. So what I want to achieve is that, if the installed version of A < 7.1.0 then upgrade of Main_package should not happen. I tried to put Conflicts tag in the spec file of Main_package as follows.Conflicts : A < 7.1.0And executed yum install *.rpmHere yum finds a latest version of package 'A' in the director...Read more

hortonworks data platform - Upgrade Grafana in HDP 2.5

Ambari uses Grafana to display metrics. I am using external data source to view other metrics. I want to upgrade grafana version from 2.6 to 4.0-beta for alerting feature.Should I upgrade grafana provided inside the HDP 2.5 packageor install new version separately?How to do this and which method is recommended?...Read more

cakephp 3.0 upgrade tool - Trouble understanding docs - Install tool where - folder to upgrade - where?

I'm trying to convert 100 models + several hundred controllers & views from cakephp 2.6.7 to cakephp 3.0.7.I've tried the following with the upgrade shell tool:download the zip fileplace into project main folder (i.e. same folder that cake 2.6.7 app resides)php composer.phar installcomposer upgrade all. This installs all of cakePHP 3.0Then the docs leave me with lots of questions...The upgrade tool provides a standalone application that can be used to upgrade other applications or cakephp plugins. Each of the subcommands accepts a path tha...Read more

upgrade - Plone 4.1.3 migration fails

Ive upgraded using buildout from 4.0.5 to 4.1.3, but when I try to upgrade (first time login) I get this:... ERROR plone.app.upgrade Upgrade aborted. Error:Traceback (most recent call last): File "/usr/local/Plone/buildout-cache/eggs/Products.CMFPlone-4.1.3-py2.6.egg/Products/CMFPlone/MigrationTool.py", line 175, in upgrade step['step'].doStep(setup) File "/usr/local/Plone/buildout-cache/eggs/Products.GenericSetup-1.6.4-py2.6.egg/Products/GenericSetup/upgrade.py", line 140, in doStep self.handler(tool) File "/usr/local/Plone/buildout-c...Read more

symfony3.4 - Upgrade symfony 2.8 or php 5.4 first?

I'll be working soon on a project and I just wanted to ask this before.The project is on symfony 2.8 with php 5.4.The goal is to upgrade symfony to 3.4 (maybe 4.x later) and php to 7.x (probably 7.2).So here is my question : is there a better order to do this?Php 5.4 to 7.2 first or symfony 2.8 to 3.4 (or it doesn't matter)?Thanks for your advices....Read more

IBM BPM 8.5.7 upgrade to 8.6

I'm going to upgrade our IBM BPM 8.5.7 server, and IBM Installation manager suggests to upgrade to IBM Business Automation Workflow.Is it correct ? IBM BPM became IBM BAW ? Is it the same licence ?As don't have any other alternative on the upgrade options....Read more

RPM upgrade uninstalls the RPM

I am upgrading our project RPM. The problem is when I upgrade from projectname-1.0-0 to projectname-1.0-1, it first installs the new project and uninstalls the old project, which, in overall view, removes my project entirely. I have used "vv" option while upgrading and the output showed the uninstallation is done after installation.Somebody please help with this problem. Is there anything I should change specifically in the RPM spec or rpmbuild options?...Read more

How to upgrade ArangoDB on Arch Linux?

I had ArangoDB 3.3.19 installed on Arch Linux. I noticed that the version in AUR was updated to 3.4, so I did this upgrade:yay -S arangodbHowever, when I started arangod after the upgrade I received this message:2018-12-22T01:25:22Z [2023] ERROR {startup} Database directory version (30319) is lower than current version (30400).2018-12-22T01:25:22Z [2023] ERROR {startup} ----------------------------------------------------------------------2018-12-22T01:25:22Z [2023] ERROR {startup} It seems like you have upgraded the ArangoDB binary.2018-12-22T...Read more

Thingsboard fails to start after upgrade to 2.3.0

After upgrading Thingsboard from 2.2.0 to 2.3.0, the service is not starting, the below error message is shown in the log. 2019-02-14 10:16:23,996 [main] ERROR o.s.boot.SpringApplication - Application startup failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'baseRuleChainTransactionService': Injection of autowired dependencies failed; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'actors.rule.transaction.queue_size' in string value "${actors.rule.trans...Read more

upgrade - Trouble upgrading odoo 8 to odoo 9

I have never used odoo, how do I upgrade from odoo 8 to odoo 9.EDIT: I have found the answer to this question and have posted the steps along. I will develop a efficient process write it down as well as any difficulties if anyone would like that message or post me.Backup the databasesBackup the server folderUninstall the odoo serverInstall the new version of odoo and after stop the odoo serviceUse a comparison tool to move changes from the Old addons folder to the new one. I use beyond compare for file and folder comparisons. This step probably...Read more

upgrade - Unable to delete registry entry: HKLM\SOFTWARE\IBM\Installation Manager\is64bit

While installing an upgraded development environment that consists of combination of WebSphere 8.5 and Eclipse, my existing development environment (RAD & WebSphere 6) got corrupted. Looks like the 8.5 corrupted the existing regystry.I uninstalled my old dev enviroment and am trying to reinstall it, but I get the error "Unable to delete registry entry: HKLM\SOFTWARE\IBM\Installation Manager\is64bit". I researched everything I could find online to resolve the problem... The one that was most promising listed on the IBM site is the one below:...Read more

upgrade - HTTP/2 with Ubuntu 18.04

I would like to try HTTP/2 on this site: https://www.alebalweb-blog.com/I recently updated the server to Ubuntu 18.04 with PHP 7.2, Apache/2.4.29, etc,etcI did: sudo a2enmod http2Added:#HTTP/2Protocols h2 h2c http/1.1In my VirtualHost SSL.and restarted Apache.The SSL certificate is provided by Let's Encrypt.The result is:curl -k -v --http2 https://alebalweb-blog.com* Rebuilt URL to: https://alebalweb-blog.com/* Trying 45.76.70.142...* TCP_NODELAY set* Connected to alebalweb-blog.com (45.76.70.142) port 443 (#0)* ALPN, offering h2* ALPN, offer...Read more

Upgrade Servicemix 4 to Servicemix 7

We are using ServiceMix 4 in our company, now due to deprecation of Java 6 we are planning to upgrade both Java and ServiceMix to the latest version.But I can see lots of configuration changes included in Servicemix 7, so how can we upgrade from SMX4 TO SMX7? Also, where can I find tutorials to learn SMX7 completely? I've done a small search and all I end up is a simple intro as mentioned in SMXx. x quickstart.pdf. All the bundles that were built previously was done by different people and is entirely different from the standard way. So I want ...Read more